Alice is so popular that she can receive many flowers everyday. She has N vases numbered from 0 to N-1. When she receive some flowers, she will try to put them in the vases, one flower in one vase. She randomly choose the vase A and try to put a flower in the vase. If the there is no flower in the vase, she will put a flower in it, otherwise she skip this vase. And then she will try put in the vase A+1, A+2, ..., N-1, until there is no flower left or she has tried the vase N-1. The left flowers will be discarded. Of course, sometimes she will clean the vases. Because there are too many vases, she randomly choose to clean the vases numbered from A to B(A <= B). The flowers in the cleaned vases will be discarded.
Input
The first line contains an integer T, indicating the number of test cases.
For each test case, the first line contains two integers N(1 < N < 50001) and M(1 < M < 50001). N is the number of vases, and M is the operations of Alice. Each of the next M lines contains three integers. The first integer of one line is K(1 or 2). If K is 1, then two integers A and F follow. It means Alice receive F flowers and try to put a flower in the vase A first. If K is 2, then two integers A and B follow. It means the owner would like to clean the vases numbered from A to B(A <= B).
Output
For each operation of which K is 1, output the position of the vase in which Alice put the first flower and last one, separated by a blank. If she can not put any one, then output 'Can not put any one.'. For each operation of which K is 2, output the number of discarded flowers.
Output one blank line after each test case.
Sample Input
2 10 5 1 3 5 2 4 5 1 1 8 2 3 6 1 8 8 10 6 1 2 5 2 3 4 1 0 8 2 2 5 1 4 4 1 2 3
Sample Output
[pre]3 7 2 1 9 4 Can not put any one. 2 6 2 0 9 4 4 5 2 3 [/pre]
Title: There are n vases, only one flower in each vase. One is to put F flowers from A. If there are already flowers in the vase, jump over the vase and put them in the next vase. The second is to empty the vase between intervals [A,B]. If it is the first operation, output the left and right endpoints of the flower; if it is the second operation, output how many flowers have been cleaned up this time. The line segment tree was established, and the nodes were maintained in the corresponding interval, without the number of vases. There are three operations: first, query the position of the k vase without inserting flowers in an interval; second, update the interval so that all the intervals insert flowers; third, update the interval so that all the vases in the interval are empty;
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define N 50010
struct node
{
int sum,b;//sumFor the number of flowers in the range, b To determine whether all is empty or all is full1,Otherwise,0
} tree[4*N];
void build(int l,int r,int i)
{
int mid = (l + r)/2;
tree[i].sum = 0;
tree[i].b = 1;
if(l == r)
return ;
build(l, mid, i*2);
build(mid + 1,r,i*2+1);
}
void Set(int l,int r,int i)
{
int mid = (l + r)/2;
tree[i*2].b = tree[i*2+1].b = 1;
if(tree[i].sum == r - l +1)
{
tree[i*2].sum=mid-l+1;
tree[i*2+1].sum=r-mid;
}
else
{
tree[i*2].sum = 0;
tree[i*2+1].sum = 0;
}
}
int QL,QR,L,R,ans,n;
void Put(int l,int r,int i)
{
if(ans<=0) return ;
int m = (l+r)/2;
if(L<=l&&r<=R&&tree[i].b)
{
if(!tree[i].sum)
{
int tans = ans;
ans -= (r-l+1);
tree[i].sum = r-l+1;
if(QL <0)
QL = l-1;
QR = r-1;
}
else
{
//The right-hand value of the bouncing flower arrangement range. R It is the smallest value on the right side of the flower, unless it exceeds the number of vases. n
R += (r-l+1);
if(R>n) R=n;
}
return ;
}
if(tree[i].b)
Set(l,r,i);
tree[i].b=0;
if(L<=m) Put(l,m,i*2);
if(R>m) Put(m+1,r,i*2+1);
tree[i].sum=tree[i*2].sum+tree[i*2+1].sum;
if(tree[i].sum==r-l+1||!tree[i].sum)
tree[i].b=1;
}
void Clear(int l,int r,int i)
{
int mid = (l+r)/2;
if(L<=l&&r<=R)
{
ans+= tree[i].sum;
tree[i].b = 1;
tree[i].sum = 0;
return ;
}
if(tree[i].b)
Set(l,r,i);
tree[i].b = 0;
if(L<=mid) Clear(l,mid,i*2);
if(R>mid) Clear(mid+1,r,i*2+1);
tree[i].sum=tree[i*2].sum+tree[i*2+1].sum;
if(tree[i].sum==r-l+1||!tree[i].sum)
tree[i].b=1;
}
int main()
{
int t,m,x;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&n,&m);
build(1,n,1);
while(m--)
{
scanf("%d %d",&x,&L);
L++;
if(x==1)
{
scanf("%d",&ans);
R = L+ans-1;
QL = QR = -1;
Put(1,n,1);
if(QR >=0)
printf("%d %d\n",QL,QR);
else
printf("Can not put any one.\n");
}
else
{
scanf("%d",&R);
R++;
ans = 0;
Clear(1,n,1);
printf("%d\n",ans);
}
}
printf("\n");
}
return 0;
}