Topic link: Point me
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements. Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
Sample Input
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
Sample Output
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
Title:
Mr. Wang wants to select some people to help him do the experiment, and the more the number, the better. But he can only choose one person, but he has to keep a small number of people who choose the person who is a direct or brief friend. What is the maximum number of people asked?
Train of thought:
We only need to select the one with the largest weights, and add their weights each time we merge.
Code:
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn = 1e7 + 10;
int ran[maxn];
int f[maxn];
bool vis[maxn];
int getf(int x){
if(f[x] == x) return x;
int tmp = f[x];
f[x] = getf(f[x]);
return f[x];
}
void Merge(int x, int y){
int t1 = getf(x);
int t2 = getf(y);
if( t1 != t2){
f[t2] = t1;
ran[t1] += ran[t2];//Merge operations, weights added
}
}
int main(){
int n;
while(scanf("%d", &n) != EOF){
if(n == 0){
printf("1\n");
continue;
}
int ans = 0;
memset(ran,0,sizeof(ran));
for(int i = 1; i <maxn; ++i)
f[i] = i,ran[i] = 1;//Initialize each weight value to be 1,
memset(vis,false,sizeof(vis));
while(n--){
int x, y;
scanf("%d %d", &x, &y);
Merge(x,y);
vis[x] = vis[y] = true;
}
for(int i = 1; i < maxn; ++i)
if(vis[i] && f[i] == i)
ans = max(ans,ran[i]);
printf("%d\n",ans );
}
return 0;
}