PAT class a real topic 1012 The Best Rank (25 points) C + + implementation (after vector sorting, map record)

Keywords: Programming

subject

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks – that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.
For example, The grades of C, M, E and A - Average of 4 students are given as the following:
StudentID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.
Output Specification:
For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.
If a student is not on the grading list, simply output N/A.
Sample Input:
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output:
1 C
1 M
1 E
1 A
3 A
N/A

thinking

The difficulty lies in figuring out the data structure of the stored information.

Establish a structure array and a ranking list for a, C, M and E grades (use unordered map to record, id as key, rank as value); sort the grades of each course, and record the sorting results in unordered map (unordered map can also be replaced by vector to improve time efficiency). For each inquired student id, find the first minimum ranking and corresponding course number in the A, C, M, E four ranking lists.

Two points need to be noted:

  1. According to the example given by the title, the average score is rounded;
  2. Test point 2 considers that when two students have the same score, they should also have the same ranking. If there is a tie first, then the ranking should be 1, 1, 3, 4

Code

#include <iostream>
#include <vector>
#include <unordered_map>
#include <algorithm>
using namespace std;

struct Info{
    int id;
    int grade;
};

bool cmp(Info i1, Info i2){
    return i1.grade > i2.grade;
}
int main(){
    int n, m;
    cin >> n >> m;
    vector<vector<Info> > g(4, vector<Info>(n)); //Four arrays store a, c, m, e
    for (int i=0; i<n; i++){
        int id;
        cin >> id;
        int sum = 0;
        for (int j=1; j<4; j++){
            cin >> g[j][i].grade;
            sum += g[j][i].grade;
            g[j][i].id = id;
        }
        g[0][i].grade = sum / 3 + 0.5; //Rounding
        g[0][i].id = id;
    }
    vector<unordered_map<int, int> > rank(4);
    for (int i=0; i<4; i++){
        sort(g[i].begin(), g[i].end(), cmp);
        int lastGrade = 101;
        int lastRank = 0;
        for (int j=0; j<n; j++){
            int id = g[i][j].id;
            if (g[i][j].grade == lastGrade){
                rank[i][id] = lastRank;
            }
            else{
                rank[i][id] = j + 1;
                lastGrade = g[i][j].grade;
                lastRank = j + 1;
            }
        }
    }
    char course[] = {'A', 'C', 'M', 'E'};
    for (int i=0; i<m; i++){
        int id; 
        cin >> id;
        if (rank[0].find(id)==rank[0].end()){
            cout << "N/A" << endl;
        }
        else {
            int best = n + 1;
            int bestCourse = -1;
            for (int j=0; j<4; j++){
                if (rank[j][id] < best){
                    best = rank[j][id];
                    bestCourse = j;
                }
            }
            cout << best << " " << course[bestCourse] << endl;
        }
    }
    return 0;
}
Published 142 original articles, won praise 7, visited 3531
Private letter follow

Posted by mahlia on Wed, 29 Jan 2020 07:54:33 -0800