Network Necessity-Dynamic Routing (Default Routing + Static + OSPF+RIP Comprehensive Experiment)

Keywords: network Mobile

The purpose of this chapter is: network interworking, R2 setting static routing, R2 and R3 using OSPF protocol in AREA1 area, R3 setting default routing back, R4 and R5 using RIP protocol.

This chapter environment: GNS3,5 routers, 4 hosts, 1 external network.

Experiment chart:

  1. Router interface address
R1: 
f0/0(192.168.10.1/24)
f0/1(192.168.20.1/24)
R2: 
f0/1(192.168.20.2/24)
f0/0(192.168.30.1/24)
R3: 
f0/0(192.168.30.2/24)
f0/1(192.168.40.1/24)
f1/0(12.0.0.1/24)
f2/0(192.168.70.1/24)
R4: 
f0/1(192.168.50.1/24)
f0/0(192.168.40.2/24)
R6: 
f0/1(192.168.60.1/24)
f0/0(192.168.50.2/24)

2. External Network Address:

R5: 
f0/0(12.0.0.2/24)
f0/1(13.0.0.1/24)

3. Client address:

PC 1: (192.168.10.2/24)
PC 2: (192.168.70.2/24)
PC 3: (13.0.0.13/24)  
PC 4: (192.168.60.2/24)

R3 routers need an extra veneer

1. Configure R1 router

R1#conf t // Enter Global Mode
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)#int f0/0//access interface
R1(config-if)#ip add 192.168.10.1 255.255.255.0//Set address
R1(config-if)#no shut // open
R1(config-if)#ex
R1(config)#int f0/1
R1(config-if)#ip add 192.168.20.1 255.255.255.0
R1(config-if)#no shut
R1(config-if)#ex
R1(config)#do show ip route // / view routing table
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.20.2 to network 0.0.0.0

C    192.168.10.0/24 is directly connected, FastEthernet0/0  //Direct connected network segment
C    192.168.20.0/24 is directly connected, FastEthernet0/1  //Direct connected network segment
S*   0.0.0.0/0 [1/0] via 192.168.20.2    //Default network

2. Configuring R2 Router Interface Address

R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int f0/1
R2(config-if)#ip add 192.168.20.2 255.255.255.0
R2(config-if)#no shut
R2(config-if)#ex   
R2(config)#int f0/0
R2(config-if)#ip add 192.168.30.1 255.255.255.0
R2(config-if)#no shut
R2(config-if)#ex

3. Configure R2 static routing and OSPF protocol

R2(config)#router ospf 1 // Enter OSPF Protocol 1 process must be in the same process in the protocol
R2(config-router)#Router-id 2.2.2//Set router-id
R2(config-router)#Network 192.168.30.0.0.0.0.255 area 1//Declare 30 segments and the backbone area area 1
R2(config-router)#redistribute connected subnets // inject R2 connected segments
R2(config-router)#redistribute static subnets // inject 10 segments of static routing
R2(config-router)#ex
R2(config)#IP route 192.168.10.0 255.255.0 192.168.20.1// / Set up static routing segment, subnet mask, next hop address
R2(config)#do show ip route   
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.30.0/24 is directly connected, FastEthernet0/0
S    192.168.10.0/24 [1/0] via 192.168.20.1
C    192.168.20.0/24 is directly connected, FastEthernet0/1

4. Configure R3 interface address

R3
R3#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R3(config)#int f0/0
R3(config-if)#ip add 192.168.30.2 255.255.255.0
R3(config-if)#no shut
R3(config-if)#int f0/1
R3(config-if)#ip add 192.168.40.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#int f1/0
R3(config-if)#ip add 12.0.0.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#int f2/0 
R3(config-if)#ip add 192.168.70.1 255.255.255.0
R3(config-if)#no shut
R3(config-if)#ex

5. Configure R3 default routing and OSPF protocol

R3(config)#IP route 0.0.0.0.0.0.0.0.12.0.0.2 sets R3 as the default route
R3(config)#router ospf 1 // Open OSPF process 1
R3(config-router)#router-id 3.3.3//Set router-id
R3(config-router)#Network 192.168.30.0.0.0.255 area 1 declares 30 segments in area 1 area
R3(config-router)#Network 192.168.40.0.0.0.255 area 0 declares 40 segments in area 0 area
R3(config-router)#Network 192.168.70.0.0.0.255 area 0 declares 70 segments in area 0 area
R3(config-router)#ex
R3(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 12.0.0.2 to network 0.0.0.0

C    192.168.30.0/24 is directly connected, FastEthernet0/0
O E2 192.168.10.0/24 [110/20] via 192.168.30.1, 00:00:49, FastEthernet0/0
C    192.168.40.0/24 is directly connected, FastEthernet0/1
O E2 192.168.20.0/24 [110/20] via 192.168.30.1, 00:00:49, FastEthernet0/0
     12.0.0.0/24 is subnetted, 1 subnets
C       12.0.0.0 is directly connected, FastEthernet1/0
C    192.168.70.0/24 is directly connected, FastEthernet2/0
S*   0.0.0.0/0 [1/0] via 12.0.0.2

6. Configure R4 interface address

R4#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R4(config)#int f0/0
R4(config-if)#ip add 192.168.40.2 255.255.255.0
R4(config-if)#no shut
R4(config-if)#int f0/1
R4(config-if)#ip add 192.168.50.1 255.255.255.0
R4(config-if)#no shut
R4(config-if)#ex

7. Configure R4RIP protocol and inject OSPF protocol

R4(config)#router rip // Enter rip protocol
R4(config-router)#ver 2 // use version 2 protocol
R4(config-router)#no auto-summary//Close routing summary
R4(config-router)#network 192.168.50.0//Announcement segment
R4(config-router)#redistribute ospf 1 metric 5 // / inject OSPF protocol into rip protocol
R4(config-router)#router ospf 1 // Open OSPF process 1
R4(config-router)#router-id 4.4.4.4
R4(config-router)#network 192.168.40.0 0.0.0.255 area 0
R4(config-router)#redistribute rip subnets
R4(config-router)#ex
R4(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.40.1 to network 0.0.0.0

O IA 192.168.30.0/24 [110/20] via 192.168.40.1, 00:00:18, FastEthernet0/0
O E2 192.168.10.0/24 [110/20] via 192.168.40.1, 00:00:18, FastEthernet0/0
C    192.168.40.0/24 is directly connected, FastEthernet0/0
O E2 192.168.20.0/24 [110/20] via 192.168.40.1, 00:00:18, FastEthernet0/0
C    192.168.50.0/24 is directly connected, FastEthernet0/1
O    192.168.70.0/24 [110/11] via 192.168.40.1, 00:00:18, FastEthernet0/0
O*E2 0.0.0.0/0 [110/1] via 192.168.40.1, 00:00:18, FastEthernet0/0

8. Configure R6 interface address

R6#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R6(config)#int f0/0
R6(config-if)#ip add 192.168.50.2 255.255.255.0
R6(config-if)#no shut
R6(config-if)#int f0/1
R6(config-if)#ip add 192.168.60.1 255.255.255.0
R6(config-if)#no shut
R6(config-if)#ex

9. Configuring R6RIP Protocol

R6(config)#router rip
R6(config-router)#ver 2
R6(config-router)#no auto-summary
R6(config-router)#network 192.168.50.0
R6(config-router)#network 192.168.60.0
R6(config-router)#ex   
R6(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.50.1 to network 0.0.0.0

R    192.168.30.0/24 [120/5] via 192.168.50.1, 00:00:21, FastEthernet0/0
C    192.168.60.0/24 is directly connected, FastEthernet0/1
R    192.168.10.0/24 [120/5] via 192.168.50.1, 00:00:21, FastEthernet0/0
R    192.168.40.0/24 [120/5] via 192.168.50.1, 00:00:21, FastEthernet0/0
R    192.168.20.0/24 [120/5] via 192.168.50.1, 00:00:21, FastEthernet0/0
C    192.168.50.0/24 is directly connected, FastEthernet0/0
R    192.168.70.0/24 [120/5] via 192.168.50.1, 00:00:21, FastEthernet0/0
R*   0.0.0.0/0 [120/1] via 192.168.50.1, 00:00:22, FastEthernet0/0

10. Configure the default routing and interface address of R5 External Network

R5R5#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R5(config)#IP route 192.168.0.0.255.255.0.0.0 12.0.0.1// set to default route
R5(config)#int f0/0
R5(config-if)#ip add 12.0.0.2 255.255.255.0
R5(config-if)#no shut
R5(config-if)#int f0/1
R5(config-if)#ip add 13.0.0.1 255.255.255.0
R5(config-if)#no shut
R5(config-if)#ex
R5(config)#do show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     12.0.0.0/24 is subnetted, 1 subnets
C       12.0.0.0 is directly connected, FastEthernet0/0
     13.0.0.0/24 is subnetted, 1 subnets
C       13.0.0.0 is directly connected, FastEthernet0/1
S    192.168.0.0/16 [1/0] via 12.0.0.1

11. Address four hosts

PC1> ip 192.168.10.2 192.168.10.1
Checking for duplicate address...
PC1 : 192.168.10.2 255.255.255.0 gateway 192.168.10.1

PC2> ip 192.168.70.2 192.168.70.1
Checking for duplicate address...
PC1 : 192.168.70.2 255.255.255.0 gateway 192.168.70.1

PC3> ip 13.0.0.13 13.0.0.1
Checking for duplicate address...
PC1 : 13.0.0.13 255.255.255.0 gateway 13.0.0.1

PC Host computer> ip 192.168.60.2 192.168.60.1
Checking for duplicate address...
PC1 : 192.168.60.2 255.255.255.0 gateway 192.168.60.1

12. Verify that the whole network is interoperable

PC1> ping 192.168.70.2
192.168.70.2 icmp_seq=1 timeout
192.168.70.2 icmp_seq=2 timeout
84 bytes from 192.168.70.2 icmp_seq=3 ttl=61 time=62.159 ms
84 bytes from 192.168.70.2 icmp_seq=4 ttl=61 time=62.159 ms
84 bytes from 192.168.70.2 icmp_seq=5 ttl=61 time=66.171 ms

PC1> ping 13.0.0.13
13.0.0.13 icmp_seq=1 timeout
13.0.0.13 icmp_seq=2 timeout
84 bytes from 13.0.0.13 icmp_seq=3 ttl=60 time=92.298 ms
84 bytes from 13.0.0.13 icmp_seq=4 ttl=60 time=92.248 ms
84 bytes from 13.0.0.13 icmp_seq=5 ttl=60 time=94.935 ms

PC1> ping 192.168.60.2
192.168.60.2 icmp_seq=1 timeout
84 bytes from 192.168.60.2 icmp_seq=2 ttl=59 time=112.913 ms
84 bytes from 192.168.60.2 icmp_seq=3 ttl=59 time=110.144 ms
84 bytes from 192.168.60.2 icmp_seq=4 ttl=59 time=116.545 ms
84 bytes from 192.168.60.2 icmp_seq=5 ttl=59 time=116.432 ms

This is our comprehensive experiment, the last experimental virtual link of OSPF in the next chapter.

Posted by coolpravin on Fri, 04 Oct 2019 21:40:53 -0700